One Bad Pixel
Soylent Green is people!
«
»

Using a Cisco 1605R with AT&T FastAccess DSL

A little primer… After having several issues with my Westell Versalink 327W DSL router provided by AT&T, my online research found that there was an issue where if you pushed a heavy load on the unit, it would either lock up or reset, either of which is brutally aggrevating. The solution mentioned is to switch the unit into bridged mode, essentially changing it from a router into a DSL modem, removing all useful functionality (although my expirements indicate that it CAN still serve DHCP, but why would you want to?) so that all it has to do is work as a media converter from DSL to Ethernet. Since it took the better part of a day to get it all figured out, I wanted to share it with everyone in case anyone is trying to do the same…

My setup is as follows: Westell Versalink 327W in bridge mode, connected to a Cisco 1605-R Router, connected to a AT 8Port 10/100 switch, connected to a couple computers and a Linksys WAP11 access point (for my servertop).

First off, the prerequisites… I highly recommend having some internet connectivity, aside from the DSL, such as your nearest neighbors wifi, but if not possible, I will try and include everything you need here.

You will need your DSL username and Password. Your username is usually username@bellsouth.net or something like that.. And you can contact them if you lost your DSL password.

Any small 10/100 switch will do, likewise, any wireless access point will do. You can use a Wireless router, but I recommend an Access point so you dont have to deal with the NAT and such.

The Cisco 1605-R is the tricky part. You should be able to pick these up just about anywhere online like eBay. If you can find one that is already upgraded to 24Mb DRAM (8Mb onboard, 16Mb SIMM), go for that, but adding the 16Mb SIMM should only cost about 30 bucks if you have to buy it. I got mine from Myriad Memory for just under $30. You will also need a FLASH RAM card that is 8-16Mb. This will cost about 50 bucks, but im sure a little searching could get them cheaper.

You will need, at the minimum, Cisco IOS 12.1(5)T, but if you upgraded the router as recommended, you might as well go to 12.3(24a). The feature pack you need is IP PLUS, or IP/FW PLUS if you intend to also use crypto VPNs on the device. Not everyone has access to Cisco CCO, so if you need help locating this software, please email me.

Now on to the setup… Assuming your router is upgraded to 12.3(24a), you have a console cable connected to the router and your favorite terminal program up and running connected to the router (You can use hypertrm in windows, putty 0.69, or whatnot). Make sure you can access the router and type commands into it.

Your computer should also be connected to the Westell router and have an IP Address assigned from it. (or statically 192.168.1.x). Browse to the Westell at http://192.168.1.254 (by default) to verify connectivity.

The first step, IMO, is to setup the 1605 so that we can continue using the internet while we work on it.
Your 1605 config should look something like this: (bold items should be adjusted for your network)

hostname home-gw
!
enable secret changeme
!
ip subnet-zero
no ip domain lookup
no ip dhcp conflict logging
!
!exclude the first 10 address for static stuff. Adjust as necessary.
!also exclude the last 5 for your router and AP factory defaults.

ip dhcp excluded-address 192.168.1.0 192.168.1.10
ip dhcp excluded-address 192.168.1.250 192.168.1.255
!
ip dhcp pool home-lan
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 205.152.37.23
lease 0 4
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0
description inbound from DSL Modem E1
no ip address
no ip proxy-arp
no ip route-cache
duplex half
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
no shutdown
!
interface Ethernet1
description outbound to LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip route-cache
no cdp enable
no shutdown
!
interface Dialer1
description AT&T FastAccess DSL
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
!bellsouth requires chap AND pap apparently, other DSL probably only needs the ppp pap sent... line
ppp authentication chap pap callin
ppp chap hostname username@bellsouth.net
ppp chap password mypass
ppp pap sent-username username@bellsouth.net password mypass
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 102 deny udp any eq netbios-dgm any
access-list 102 deny udp any eq netbios-ns any
access-list 102 deny udp any eq netbios-ss any
access-list 102 deny udp any range snmp snmptrap any
access-list 102 deny udp any range bootps bootpc any
access-list 102 deny tcp any eq 137 any
access-list 102 deny tcp any eq 138 any
access-list 102 deny tcp any eq 139 any
dialer-list 1 protocol ip list 102
!
!set a password on the vty unless you want to console into this using serial
line vty 0 4
password letmein
end

Now write your config so you dont lose it all. Providing you typed in the right password for your DSL, we should be all ready for the next part.

Now, we have to make the Westell router become stupid. Using a pen, hold the reset button on the back for 30 seconds. After another 30 seconds, open a browser on your computer. It should redirect you to a page asking you to setup your router username and password. This may be slightly different for non-Bellsouth FastAccess customers, but the overall result is the same. Setup your bellsouth userID and password and hit next. It asks you to setup some auto-updates settings. Its up to you, I chose not to, as I prefer manually updating. Hit next and it should tell you to close your browser and re-open it. Do so.

For the next step, I found using firefox seemed to work a little better. Also, try clearing your browser cache.
Browse to some website, such as http://www.onebadpixel.com/blog to verify your Internet is still working at this point. It should be. Goto http://192.168.1.254 to access your router settings. On the “Home Network” tab, edit the settings and disable dhcp. Now, goto the Broadband DSL Line tab and click the Edit Connection button. (If you are lucky like me, at this point your Westell Router is acting like a horses arse and pissing you off, no wonder the thing works like crap). Be patient if its slow.
There is an option to change it from PPPoE to Bridged. You want to change this to bridged so that we can let the 1605 do the authentication for us. After changing it to bridged, it will immediately refresh and have less options and probably take forever to finish loading. Click save, then when it reloads, click save and reset connection.

Once the westell is in bridged mode, the Internet light on it should turn off (the little globe). This is normal and indicates that it no longer can connect to the internet (because it has no ip and intelligence).

On a side note, it is possible to overload the ethernet switch ports on the westell and use them to connect to the cisco 1605 on a single ethernet port as a single-armed router. If you want this adjusted config, please let me know. I used it like this while my 8port switch was dead for a little while.

After converting to bridge mode, if the westell E1 is connected to the 1605 E0 and you are still on the console, you should see the dialer1 interface come up. You can use “show pppoe session” to see if it is up, it should look something like

Total PPPoE sessions 1

PPPoE Session Information
UID SID RemMAC OIntf Intf Session
LocMAC VASt state
0 47448 0003.42d8.60c3 Et0 Vi1 N/A
00d0.58a8.fb3c UP

and the Interface to watch is Vi1.

Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1492 bytes, BW 56 Kbit, DLY 20000 usec,
reliability 255/255, txload 9/255, rxload 9/255
Encapsulation PPP, LCP Open
Listen: CDPCP
Open: IPCP
PPPoE vaccess, cloned from Dialer1
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
Interface is bound to Di1 (Encapsulation PPP)
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 02:34:59
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 2000 bits/sec, 2 packets/sec
5 minute output rate 2000 bits/sec, 2 packets/sec
79359 packets input, 48721718 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
53335 packets output, 7284718 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

All said and done, you should now have your Westell now acting as a DSL Modem, and your 1605-R doing all the work. My next article on this will be adding a VPN tunnel to a Cisco 3030 VPN Concentrator from here also.

 

5 Responses for “Using a Cisco 1605R with AT&T FastAccess DSL”

  1. Frank Says:

    Hi, i’e tried many different ios ive found on the net and non of them was having thhe ip package…could you snd me the vsion of on of that ios so i can throw away my old dlink??

  2. Jim Says:

    Frank, I used this config for quite some time, but found that the 1605R is just not fast enough to keep up with DSL or cable. It experiences heavy collisions and dramatically reduces your throughput. If you still want the IOS, let me know, but I have since upgraded to a 2611XM which is capable of handling the 10Mb/s I have now.

  3. Bob Says:

    I was given a free 1605R and want to set it up for a friend for basic net access. Can you send the IOS version mentioned in this post? Thanks in advance

  4. redflagdeals.com Says:

    Different services can help you find the perfect place for you and advice you what to do to reach it.
    Many times if you use our suggestion you will find that the quality backpacks are the same price as the cheaply made backpacks.
    Adult comfort – It is all well and good to have your baby comfortable, but if your back carrier is not comfortable then you will not be going far (or you will only be doing it once.

  5. Rolland Says:

    You have to throw the collected dirt from the container in the garbage can in your
    backyard or outside your house to prevent the dust and dirt from getting back into your house.
    As can be seen from the above applications, cleaners of this type have a wide variety of uses.
    Of course, because a vacuum appliance is very important in our lives, we
    must do all we can to make sure that service continues for
    a longer period of time.

Leave a comment!